Printers Missing from Some Dialogs
How Can We Help?
Issue
While logged into the cloud you do not see your local printers in the following areas
- The Immersive Control panel in Devices > Printers & scanners
- The Legacy Control Panel Devices and Printers
- When using the Print Dialog of Modern UI applications. Such as Microsoft Photos.
Cause
Printer redirection has a known issue with the local computer name being too long. If the local computer name exceeds 14 characters Remote Desktop Services will have an issue redirecting printers properly in the listed cases above.
To check the the length of your computers name you may run the following in Windows Powershell
$env:COMPUTERNAME.Length
Solution
To resolve this please rename your computer to a name no more than 14 characters using the following methods.
- Right Click the Start Menu and Choose system, or
Open Settings (Gear Icon) then System > About - Click on Rename this PC
- Enter a new Name. Make sure not to exceed 14 characters. Example the current PC name with the last character missing.
- Click Next
- Click Restart Now
- Right Click on the Start Button, or
Press the Windows Key + R - Enter Control System and click ok
- Click on Change Settings in the Computer name, domain, and workgroup settings.
- Click on the Change Button
- Remote the Last character from Computer name and press ok
- Click OK
- Press Close.
- Click Restart Now
- Right Click the Start Button
- Click on Windows Powershell (Admin)
- Confirm Administrator Elevation (If you are not an administrator on the local computer enter the credentials of an administrator account)
- in the powershell command prompt enter the following command (Make sure all work is saved, computer will automatically reboot)
Rename-Computer -NewName $env:COMPUTERNAME.Substring(0,14) -Restart
These walk throughs assume you have upgraded Windows 10 to at least version 1903